Announcement Announcement Module
Collapse
No announcement yet.
default queues not deleted Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • default queues not deleted

    Hi I am running spring integration with amqp gateways and the amqpTemplate is configured as follows:

    Code:
    <template id="amqpTemplate" connection-factory="connectionFactory" reply-timeout="15000"/>
    From my understanding, this means that I am creating default queues that should be deleted after 15000 ms. Sometimes I see that these queues are created but never deleted. What could be the reason?

    Thanks
    Netta

  • #2
    Can you show the rest of your configuration that is related to the AMQP gateway and any configuration you have for Exchanges, Queues, and Bindings?

    Thanks,
    Mark

    Comment


    • #3
      This is the rabbit amqp code:

      Code:
      <beans:beans xmlns="http://www.springframework.org/schema/rabbit"
      	xmlns:beans="http://www.springframework.org/schema/beans" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      	xsi:schemaLocation="http://www.springframework.org/schema/rabbit http://www.springframework.org/schem...rabbit-1.0.xsd
      	http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd">
      
      	<beans:beans profile="production">
      		<connection-factory id="connectionFactory" host="${rabbitmq.agent.host}"
      			port="${rabbitmq.agent.port}" password="${rabbitmq.agent.password}" />
      
      		<template id="amqpTemplate" connection-factory="connectionFactory" reply-timeout="15000"/>
      
      		<admin connection-factory="connectionFactory" />
      	</beans:beans>
      </beans:beans>
      and this is the spring-integration code:

      Code:
      <?xml version="1.0" encoding="UTF-8"?>
      <beans xmlns="http://www.springframework.org/schema/beans"
      	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:int="http://www.springframework.org/schema/integration"
      	xmlns:int-amqp="http://www.springframework.org/schema/integration/amqp"
      	xmlns:rabbit="http://www.springframework.org/schema/rabbit"
      	xmlns:int-stream="http://www.springframework.org/schema/integration/stream"
      	xsi:schemaLocation="http://www.springframework.org/schema/integration/amqp http://www.springframework.org/schem...ation-amqp.xsd
      		http://www.springframework.org/schema/integration http://www.springframework.org/schem...ration-2.1.xsd
      		http://www.springframework.org/schem...gration/stream http://www.springframework.org/schem...stream-2.1.xsd
      		http://www.springframework.org/schema/rabbit http://www.springframework.org/schem...rabbit-1.0.xsd
      		http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd">
      
      	<int:channel id="requestChannel" />
      	<int-amqp:inbound-gateway id="inboundGateway"
      		request-channel="requestChannel" connection-factory="connectionFactory"
      		queue-names="${rabbitmq.request.queue}"
      		mapped-request-headers="requestType" />
      
      	<int:channel id="fooServiceChannel" />
      	<int:channel id="booServiceChannel" />
      
      	<int:header-value-router id="router"
      		header-name="requestType" input-channel="requestChannel">
      		<int:mapping value="${foo.header}"
      			channel="fooServiceChannel" />
      		<int:mapping value="${boo.header}"
      			channel="booServiceChannel" />
      	</int:header-value-router>
      
      	<int:service-activator input-channel="fooServiceChannel"
      		ref="fooService" method="foo" />
      
      	<int:service-activator input-channel="booServiceChannel"
      		ref="booService" method="boo" />
      		
      	<beans profile="production">
      		<rabbit:queue name="${rabbitmq.request.queue}">
      			<rabbit:queue-arguments>
      				<entry key="x-message-ttl">
      					<value type="java.lang.Long">60000</value>
      				</entry>
      			</rabbit:queue-arguments>
      		</rabbit:queue>
      	</beans>
      
      </beans>
      Thanks
      Netta

      Comment


      • #4
        Any suggestions why the default queue being created doesn't get dropped some of the time?

        Thanks
        Netta

        Comment

        Working...
        X