Announcement Announcement Module
Collapse
No announcement yet.
Spring AMQP and Spring 2.5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring AMQP and Spring 2.5

    Hi,

    I created one successful independent POC with spring amqp RC2 jars and used spring 3.0 jars absent mindedly. I am trying to integrate it with Spring 2.5 now (which is being used in our project) but getting compile time errors. Is there any particular build of Spring AMQP which can work with Spring 2.5 jars?

  • #2
    I would be very surprised if you could get Spring AMQP working with Spring 2.5. We build and test against 3.0.5. I'd be interested to hear more about the errors though.

    Comment


    • #3
      When compiling with Spring 2.5, the first error I got was about a missing class in Spring-Context jars. Sorry that I don't remember the class name now.

      The result was that I had to use to RabbitMQ Java APIs (instead of Spring AMQP) to make it work with Spring 2.5 jars (as it's not feasible to upgrade Spring jars very quickly in production).

      Comment

      Working...
      X