Announcement Announcement Module
Collapse
No announcement yet.
spring-amqp with spring 2.5? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spring-amqp with spring 2.5?

    I have two related projects; one a new routing project using spring 3.0, spring-integration and spring-amqp, and another legacy project that is currently on spring 2.5. which receives the routed messages.

    The spring 3.0 project was relatively easy to get up and running with spring-amqp, but I am having some problems incorporating the spring-amqp into the spring 2.5 project. I am rather short of time to migrate the spring 2.5 project to spring 3.0 (although I hope to do that at some point).

    Before I put a lot more effort into getting spring-amqp running within the spring 2.5 project, is that even feasible? If I need to I can hand code the rabbitmq java client directly in without the aid of spring-amqp, but it seems like I shouldn't have to do so.

    If I *should* be able to easily incorporate spring-amqp into the spring 2.5 project I will continue to work through it, and if necessary post configurations and errors if I am unable to diagnose my screwup. (e.g. I am getting a "The type org.springframework.jmx.support.MetricType cannot be resolved. It is indirectly referenced from required .class files")

  • #2
    Spring AMQP requires Spring 3.0. The officially supported version as provided in the parent POM is 3.0.5.RELEASE.

    Comment


    • #3
      Thank you for the response. I was able to code the rabbitmq client directly in just a couple hours, including tests. I was not aware of the parent POM linkage to version (it seems obvious now).

      Comment

      Working...
      X