Announcement Announcement Module
Collapse
No announcement yet.
Maven Repository URL Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maven Repository URL

    I have been attempting to retrieve Spring artifacts from the published Spring Maven repository http://repository.springsource.com/m...undles/release (or anything under http://repository.springsource.com/maven) and I keep getting 404's.

    Is there a new location for the Spring Maven repositories?

    Thanks!

  • #2
    Please read this: http://www.springsource.org/node/2962

    Comment


    • #3
      Originally posted by oleg.zhurakousky View Post
      Thanks for the link, I also get a 404 when attempting to get to http://maven.springframework.org/release

      Is it just my network that is giving me these issues?

      Comment


      • #4
        Probably

        The 3 repos that we use for milestones, snapshots and releases are:
        Code:
        <repositories>
        		<repository>
        			<id>repository.springframework.maven.release</id>
        			<name>Spring Framework Maven Release Repository</name>
        			<url>http://maven.springframework.org/release</url>
        		</repository>
        		<repository>
        			<id>repository.springframework.maven.milestone</id>
        			<name>Spring Framework Maven Milestone Repository</name>
        			<url>http://maven.springframework.org/milestone</url>
        		</repository>
        		<repository>
        			<id>repository.springframework.maven.snapshot</id>
        			<name>Spring Framework Maven Snapshot Repository</name>
        			<url>http://maven.springframework.org/snapshot</url>
        		</repository>
        </repositories>

        Comment


        • #5
          I understand this, but I'm currently getting a not found when I attempt to not only use the repository but also load them in the web browser (as a test).

          I just looked in maven central (as the other part of the post suggested) and didn't realize that the 3.0.x releases were also in that repository. I only saw up to 2.5.6 in my nexus cache, so I will use maven central and figure out what's wrong with my nexus cache.

          Thanks for your help, I really appreciate it!

          Comment


          • #6
            I'm experiencing the same problem at the moment. None of the following repositories can be accessed at the moment (and they have worked for me previously!). This leads me to conclude that there is some sort of operations problem right now (I tested yesterday and today):

            Code:
            <repository>
            			<id>repository.springframework.maven.release</id>
            			<name>Spring Framework Maven Release Repository</name>
            			<url>http://maven.springframework.org/release</url>
            		</repository>
            		<repository>
            			<id>repository.springframework.maven.milestone</id>
            			<name>Spring Framework Maven Milestone Repository</name>
            			<url>http://maven.springframework.org/milestone</url>
            		</repository>
            		<repository>
            			<id>repository.springframework.maven.snapshot</id>
            			<name>Spring Framework Maven Snapshot Repository</name>
            			<url>http://maven.springframework.org/snapshot</url>
            		</repository>
            The following root URL does work for me when accessed from a browser: http://maven.springframework.org, but the above sub-paths do not work at all, whether accessed from a browser, from a maven build configured with the explicit repositories, or proxied by Nexus. The Nexus "Browse Remote" feature also fails to work for these repositories at the moment.

            Comment


            • #7
              Those are repository URLs and are not intended to be directly accessible via the browser. If you need to browse the repository, you can use a utility such as this: http://shrub.appspot.com/maven.springframework.org/

              Hope that helps.
              -Mark

              Comment


              • #8
                Ok, I wasn't completely correct before. I am able to use the repositories if I bypass our corporate Nexus proxy. So, the issue here seems to be with Nexus not being able to proxy these particular Spring repositories. This has worked fine previously but doesn't seem to be working right now. And this is unfortunately a showstopper for sharing my current project with my co-workers.

                However, I don't think this is an issue with Nexus, since it is able to proxy other S3-backed repositories such as the Spring EBR repositories.

                My theory is that perhaps some metadata or configuration has changed on these repositories which makes Nexus unable to proxy them?

                I've verified that our Nexus isn't misconfigured, I've also reproduced the issue on a fresh local install of Nexus: Spring EBR repositores are proxied just fine, the "Maven Central compatible" Spring repositories we're talking about refuse to allow themselves to be proxied.

                Any theories?

                Comment


                • #9
                  All I can say is that we have many users who are using nexus and other proxies successfully, so if you are sure that nexus is not misconfigured, then check with your network admin to see if that repository or urls blocked from the server where nexus is running

                  Comment


                  • #10
                    Steve

                    You may also want to look at this issue which might be related
                    https://jira.springsource.org/browse/INT-1368

                    I am also going to ping few guys who might have some more insights.

                    Comment


                    • #11
                      Thanks,

                      I just verified that this only occurs with the latest version of Nexus, 1.8.0.1, so I'm taking this to the nexus mailing list.

                      Comment


                      • #12
                        I have the same issue with nexus 1.8.0.1 too (free version).
                        If you have some news about this, I am interested

                        Comment


                        • #13
                          We using Nexus
                          Code:
                          Sonatype Nexus™ Open Source Edition, Version: 1.8.0
                          I have this repository:
                          Code:
                          Repository ID: spring-milestone
                          Repository Name: Spring Repository
                          Repository Type: proxy
                          Repository Policy: Release
                          Repository Format: maven2
                          Contained in groups: 
                          
                          Remote URL: http://maven.springframework.org/
                          And all I'm not able to browse remote (und use) is: milestone

                          Where is my fault?

                          Or which else repository can I use as a proxy to get
                          Code:
                             <dependency>
                                <groupId>org.springframework.security.extensions</groupId>
                                <artifactId>spring-security-kerberos-core</artifactId>
                                <version>1.0.0.M2</version>
                             </dependency>
                          Thanks and cheers

                          Heinrich
                          Last edited by hank; Feb 3rd, 2011, 04:48 AM. Reason: describe the root reason for the problem

                          Comment


                          • #14
                            Hi,

                            I still have the issue with my local nexus which cannot access the milestone spring repo.

                            So what I have to do is to manually upload the artifacts after getting them through the broswer (appspot...).

                            This is really annoying plus I don't get the source if I do a maven eclipse:eclipse.

                            I am using nexus 1.6.0 behind a proxy. Other repos work fine.

                            I would be happy to get some help here.

                            thank you

                            Ludovic

                            Comment


                            • #15
                              by the way there is this issue which seems related:
                              https://jira.springsource.org/browse/SESURF-75

                              Comment

                              Working...
                              X