Announcement Announcement Module
Collapse
No announcement yet.
FTP inbound channel adapter Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • FTP inbound channel adapter

    Is there a simple ftp file download example to see.

    I tried a simple file transfer but the output file written were 0 bytes and INCOMPLETE suffix.

    What could be wrong. Any working example would be great to start looking.

    Thanks

  • #2
    Have you checked out the samples repository?

    Comment


    • #3
      I did and I have done noting different but seems not working

      I come across this link.

      https://jira.springframework.org/browse/INT-1663


      may be i need to wait for a 2.0.1 release - dont know ???

      Comment


      • #4
        Yes its true, there was a bug that has been fixed. The code is available with nightly snapshots and will be available with 2.0.1 which should be today.
        Sorry about this.

        Comment


        • #5
          is that possible to provide a download link - for 2.0.1 or the nightly build ?

          Comment


          • #6
            Are you using Maven?

            Comment


            • #7
              No, not for this work - shame I know. The good old ant :-)

              Comment


              • #8
                Okay. If you just want to download the snapshot distribution zip, you can find it here: http://shrub.appspot.com/dist.spring.../snapshot/INT/

                Comment


                • #9
                  Will do that and update after my test pass.

                  thanks

                  Comment


                  • #10
                    well am not sure this is working - may be something i am doing wrong.

                    To down load a file all i need is to define the ftp:inbound-channel-adapter
                    with local-directory,remote-directory,session-factory ?

                    any simple example ?

                    Comment


                    • #11
                      The simplest FTP example is in the sample repo that was pointed out by Brandon earlier. My bigger concern is are you sure you are using the latest snapshot? The problem you are describing is exactly what was reported earlier and was fixed with that issue

                      Comment


                      • #12
                        I have downloaded the 2.0.1 build and am sure that i have got that in my classpath in STS.

                        please check anything obviously wrong in the attached xml configuration file.

                        This xml with remote-directory="test" writes a <inputfilename>.xml.writting file and error with 550 failed to open file.

                        I could do same operation (get) outside on windows cmd line being same user. So I dont think any permission issue.

                        Comment


                        • #13
                          Try to put a '/' at the end of the remote-directory (e.g. remote-directory="test/")

                          Comment


                          • #14
                            no good -

                            when I put test/ with localdirectory file:c:/test/out it seems creating a file with .writting and error on console saying test/\filename.xml . server replied 501 invalid file or file name

                            "test\" - is not working and not giving any error either. I tried most of the possible combinations but seems no result.

                            Just wanted to make sure do i need a file out bound to write the file or anything like that. I have tried only with ftp inbound and stderror for error channel.

                            I am stuck and dont have much time to finish this task so might go and use apache ftpclient directly.
                            Last edited by arungn; Dec 15th, 2010, 03:22 AM.

                            Comment


                            • #15
                              Well one thing i noticed is that you using fileType=3. We only support binary (2) and ascii (0) for now, so I am not sure if that causes the issue.

                              Also
                              What is your FTP server and what platform it is running on?
                              I am also assuming that you transferring it to windows?
                              Can you transfer it through CLI (ftp get)?

                              Could you also make sure that your program does not exit before the file is fully transferred in case your file is big.

                              Can you also look at the FTP samples? It has both Inbound and Outbound sample.

                              Comment

                              Working...
                              X