Announcement Announcement Module
Collapse
No announcement yet.
Running samples in Virgo Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running samples in Virgo

    Fresh install of virgo-kernel-2.1.0.RELEASE
    Copy spring-integration-1.0.4.RELEASE/dist/*.jar to virgo/repository/usr
    Build spring-integration-1.0.4.RELEASE/samples/cafe
    Copy cafe-1.0.4.jar to virgo pickup/
    Get this message:
    Caused by: org.eclipse.virgo.kernel.osgi.framework.UnableToSa tisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'org.springframework.integration.samples.cafe' at version '1.0.4': A library with the name 'org.aspectj' and a version within the range '[1.6.2.RELEASE, 1.7.0)' could not be found

    Lookup up org.aspectj on SpringSource Enterprise Bundle Repository and found:
    com.springsource.org.aspectj.runtime
    com.springsource.org.aspectj.weaver

    I have tried downloading these 2 bundles and placing them just about everywhere I can find in Virgo (reporitory/usr, lib, pickup, etc).

    I have tried running the cafe sample in Apache Felix. In Felix, I was able to "install" the two aspectj jars, and then install cafe, but when starting the cafe bundle, nothing happens. It says the cafe bundle is resolved, yet it doesn't seem to do anything when started.

    Any suggestions? I have spent a lot of time reading through documentation on Virgo, Felix, etc and can not seem to find what needs to be done to satisfy the "Library" dependency on aspectj. The whole Import-Library mechanism seems a bit nebulous to me. Apparently I haven't found the proper document to really explain this yet.

    Thanks in advance.

  • #2
    I found the *.libd information and am now able to download .libd files for the various libraries. I am still getting errors and am unable to run the samples yet, but hope I am making progress again.

    I still have to figure out where "trace" goes in order to see the cafe sample actually do something and have to work through a couple import conflicts WRT aspectj packages.

    Comment


    • #3
      I have SI 2.x running against the virgo kernel runtime. The 2.x samples don't have support for OSGi built in.

      I started out in STS with the Virgo web server runtime configured, and added the simplest 2. x sample (hello) project, then in Spring Tools menu, added OSGi Bundle project nature, targeted Virgo runtime, and built up the MANIFEST.MF (with added an activator):
      Code:
      Manifest-Version: 1.0
      Bundle-Version: 1.0.0
      Bundle-Name: Hello
      Bundle-ManifestVersion: 2
      Bundle-SymbolicName: hello
      Import-Package: org.osgi.framework;version="[1.5.0,1.5.0]",
       org.slf4j;version="[1.6.1,1.6.1]"
      Bundle-Activator: hello.Activator
      Import-Library: org.springframework.spring;version="[3.0.0,3.1.0]"
      Import-Bundle: org.springframework.integration;version="[2.0.0,2.1.0]"
      Running against the virgo kernel is pretty much the same, without the web support. Here's how to upgrade the kernel runtime to the latest spring framework libs.

      Comment

      Working...
      X