Announcement Announcement Module
Collapse
No announcement yet.
SI 2.0 RC1 Dependency Error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SI 2.0 RC1 Dependency Error

    Hi,

    I am playing with moving from si 1.0.4 to si 2.0 RC1. When I load my app context with si 2.0 RC1 in the classpath I get a class not found exception. My Spring core is 3.0.0RELEASE.

    GatewayMethodInboundMessageMapper tries to import, org.springframework.expression.BeanResolver but that class in Spring 3.0.0RELEASE that class doesn't live in springframework.expression package.

    What is the dependency on spring framework for si 2.0?

  • #2
    Spring Integration 2.0.0.RC1 depends on Spring 3.0.5.RELEASE.

    Comment

    Working...
    X