Announcement Announcement Module
No announcement yet.
Eclipse unable to validate xsd-2.0 Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eclipse unable to validate xsd-2.0


    I am using Eclipse Galileo with Spring IDE (Version: and STS (Version: 2.3.0.RELEASE), and Spring Integration 2.0.0.M7 and Spring 3.0.4.RELEASE.

    When I am opening spring bean configuration file in the Spring Config Editor, though I am using the xsd-2.0 namespaces, its still taking xsd-1.0 and unable to recognize the 2.0 specific attributes and showing errors as shown in the attached screenshot (attachment1.png).

    Initially according to a different post, i thought that the xsd is not getting cached in the Xml Catalog, but that does not seem to be the case (attachment2.png).

    <?xml version="1.0" encoding="UTF-8"?>
    <beans xmlns=""
    	xmlns:xsi="" xmlns:int=""
    	<int:annotation-config />
    		id="productServiceGateway" default-request-channel="productServiceOperations" />
    	<int:channel id="productServiceOperations" />
    	<http:outbound-gateway id="httpGateway"
    		http-method="GET" expected-response-type="" />
    	<bean id="xstreamMarshaller" class="org.springframework.oxm.xstream.XStreamMarshaller">
    		<property name="annotatedClass"
    			value="" />
    This is however, working on build and deployment as expected.

    Please advise.

  • #2
    The problem is that the version of STS you are using has an older version of the 2.0 schema in its plugin.

    Even if you upgrade to STS 2.3.2 (which allows you to set an option to find the schemas on the classpath), STS will still use the old schemas that are in the XML Catalog (see

    You can detour this by putting the schemas on your filesystem some place and creating manual XML catalog entries (see the above JIRA for an example).

    Or, if you update to STS 2.5.0.M3, you will pick up most (but not all) schema updates.

    Edit: Oh, and you can play with the new GUI Spring Integration Editor too!


    • #3
      STS new release timeline

      Hi Gary,

      Thanks for the quick update. I will upgrade it to 2.5.0.M3, but I could not see any roadmap or a project timeline when we are expecting a RELEASE version for STS. Integration 2 i guess is expected by October, is the new STS expected around the same time?


      • #4
        With STS 2.5.0.M3, there is an option (Window | Preferences | Spring | Beans Support | Namespaces | Load Namespace Handlers and XSDs from project's classpath). It is also settable at the individual project level.

        If you set that, STS will always use the schemas in the jars on your classpath.

        The option has been available since 2.3.2 and worked for "new" schemas that were not already in the catalog (the catalog took precedence for existing schemas); it has since been changed so that a classpath schema will take precedence.


        • #5
          Issues in 2.5.0. Milestone STS


          I tried the steps and though 2.3.2 doesn seem to recognise the integration XSDs, 2.5.0.CI-R5706-B362 did after doing the modification for Namespace Handling as mentioned in your reply.

          However, I guess some issues are yet to be fiixed before release, and I just wanted to inform that I am getting this problems:

          1. Internal error while "Processing Dirty Regions"
          2. During " Initialise bean graph"

          The screen shots are attached for your reference. (attachment3.png)




          • #6
            Thanks for the feedback.

            May I ask you to post your new issues here... ?

            Feel free to refer back to this thread there.