Announcement Announcement Module
Collapse
No announcement yet.
Si 2.0.0.m1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Si 2.0.0.m1

    If I want to use the web service support in SI 2.0.0.M1 am I likely to encounter any issues as this version SI is dependant on version 3.0.0 of the Spring Framework but the version of Spring Web Services (1.5.8) is still dependant on 2.5.6

  • #2
    Spring Web Services 1.5.8 supports Spring 3.0, so you should not have any problems using them together.

    Comment


    • #3
      Ahhh ok thanks Mark. I had just assumed it used 2.5.6 from doing a maven dependancy tree report on SI

      Code:
      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Spring Integration Web Services Support
      [INFO] 
      [INFO] Id: org.springframework.integration:spring-integration-ws:jar:2.0.0.BUILD-SNAPSHOT
      [INFO] task-segment: [dependency:tree]
      [INFO] ------------------------------------------------------------------------
      [INFO] [dependency:tree]
      [INFO] org.springframework.integration:spring-integration-ws:jar:2.0.0.BUILD-SNAPSHOT
      [INFO] +- com.sun.xml.messaging.saaj:saaj-impl:jar:1.3:provided
      [INFO] +- javax.xml.soap:saaj-api:jar:1.3:provided
      [INFO] |  \- javax.activation:activation:jar:1.0.2:provided
      [INFO] +- stax:stax:jar:1.2.0:provided
      [INFO] |  \- stax:stax-api:jar:1.0.1:provided
      [INFO] +- org.springframework.integration:spring-integration-adapter:jar:2.0.0.BUILD-SNAPSHOT:compile
      [INFO] |  +- org.springframework:spring-context:jar:3.0.0.RC1:compile
      [INFO] |  |  +- aopalliance:aopalliance:jar:1.0:compile
      [INFO] |  |  \- org.springframework:spring-asm:jar:3.0.0.RC1:compile
      [INFO] |  \- org.springframework.integration:spring-integration-core:jar:2.0.0.BUILD-SNAPSHOT:compile
      [INFO] |     \- org.springframework:spring-tx:jar:3.0.0.RC1:compile
      [INFO] +- org.springframework:spring-oxm:jar:3.0.0.RC1:compile
      [INFO] |  +- org.springframework:spring-beans:jar:3.0.0.RC1:compile
      [INFO] |  \- org.springframework:spring-core:jar:3.0.0.RC1:compile
      [INFO] +- org.springframework.ws:spring-ws-core:jar:1.5.8:compile
      [INFO] |  +- commons-logging:commons-logging:jar:1.1.1:compile
      [INFO] |  +- org.springframework.ws:spring-xml:jar:1.5.8:compile
      [INFO] |  +- org.springframework.ws:spring-oxm:jar:1.5.8:compile
      [INFO] |  +- org.springframework:spring-aop:jar:2.5.6:compile
      [INFO] |  +- org.springframework:spring-web:jar:2.5.6:compile
      [INFO] |  +- org.springframework:spring-webmvc:jar:2.5.6:compile
      [INFO] |  |  \- org.springframework:spring-context-support:jar:2.5.6:compile
      [INFO] |  \- wsdl4j:wsdl4j:jar:1.6.1:compile
      [INFO] +- junit:junit:jar:4.7:test
      [INFO] +- org.springframework:spring-expression:jar:3.0.0.RC1:runtime (scope not updated to compile)
      [INFO] +- org.springframework:spring-test:jar:3.0.0.RC1:test
      [INFO] \- org.mockito:mockito-all:jar:1.6:test
      As you can see it reported as using parts of 2.5.6 (spring-aop, spring-web, spring-webmvc, spring-context-support) and OXM from Spring WS 1.5.8 as well as Spring 3.0.0.RC1

      Comment


      • #4
        Spring 2.5.6 is the minimal version dependency for Spring WS 1.5.8.

        If you look at the Maven dependencies from the Spring Integration (2.0 M1) side, you'll see that it relies on Spring WS 1.5.8 and Spring 3.0 RC2.

        In an OSGi environment, the ranges are used to negotiate across the different versions. Are you going to be running in an OSGi environment?

        Comment


        • #5
          No, it's a clustered WebSphere environment

          Comment


          • #6
            I have seen similar things in a project I am working on.

            I have an EAR file containing 2 WARs. Both WARs have Spring Framework 3.0.0.RC1 as a dependency but one of the WARs also depends on Spring Integration 2.0.0.M1. I have structured my EAR/WARs so that the common dependencies are in the EAR and specific dependencies are in the individual WARs. However because of the 2.5.6 dependency of Spring WS I have had to explicitly exclude the Spring Framework dependencies that are pulled in by the spring-integration-ws project to avoid conflicts. I am a bit concerned about whether this is the correct thing to do or not as I'm not sure how well Spring WS 1.5.8 plays with Spring Framework 3.0.0.RC1.

            Finally I have also downloaded the latest Spring Integration code from the subversion repository and loaded this into Springsource Tool Suite and used the m2Eclipse plugin to build the projects. The Maven Dependencies container for the spring-integration-ws project contains a mixture of Spring Framework 2.5.6 and 3.0.0.RC1 jar files and also (more worryingly I think) contains both spring-oxm-1.5.8.jar and spring-oxm-3.0.0.RC1.jar. If this is not noticed and corrected by any application including spring-integration-ws as a dependency I am not sure which one of these would be used at runtime!!

            Comment


            • #7
              I encountered this in my project at some point (I don't remember if it was on a BUILD-SNAPSHOT prior to M1 or M1 itself). Excluding 2.5.6 helped, and the latest BUILD-SNAPSHOT doesn't have this problem iirc.

              Update: I checked and it seems that the problem I had on my project was related to the xml module (not the ws module). The mentioned dependency problem is still there. If you add the proper exclusions you should be fine, but it pays off to add an issue for this so we don't miss it for M2.
              Last edited by iwein; Nov 8th, 2009, 04:03 AM. Reason: checked dependency graph of svn HEAD

              Comment

              Working...
              X