Announcement Announcement Module
Collapse
No announcement yet.
JMS Outbound Channel Adapter with message expiration Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • JMS Outbound Channel Adapter with message expiration

    Hi, I am using Spring Integration 1.0 and ActiveMQ 5.2.

    I need to send message with expiration, google show me this where the producer shall set the time to live:
    http://activemq.apache.org/how-do-i-...xpiration.html

    When I try with Spring Integration JMS outbound channel adapter, I cant find a properties to set the time to live. May I know where shall I set it?

    Thank you.

  • #2
    I have the same problem here.

    Comment


    • #3
      It seems that we need to add this to JmsHeaders. Is that what you are suggesting? If so, please raise an issue in JIRA.

      Thanks,
      Mark

      Comment


      • #4
        https://jira.springsource.org/browse/INT-890

        Comment


        • #5
          Thanks for adding the issue. Basically, we need to do the following:

          1) Add support for several attributes that are normally configured directly on JmsTemplate so that they can be added to the adapter element instead.
          2) Allow a "jmsTemplate" reference along with an explicit "destination" (or name) on the adapter element.
          3) Consider any of these values that should also be available via JmsHeaders on a per-Message basis.

          I would like to get some feedback on #3 above.... in terms of actual use-cases where adapter-level settings are not fine-grained enough.

          Comment


          • #6
            Can timetolive be set with MessageBuilder?

            I see this thread talks about a fix in the jms outbound adapter bean XML configuration. But is it possible to set the Time to live with the MessageBuilder? I've tried to use MessageBuilder.setExpirationDate(currentTimeInMill is + 100) only it seems that ActiveMQ broker still happily delivers the message.
            And I am not sure if it should work, if it is some ActiveMQ setting issue or what.
            Thanks!

            Comment

            Working...
            X