Announcement Announcement Module
Collapse
No announcement yet.
Newbie - Compile spring integration source question Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newbie - Compile spring integration source question

    I encounter a problem whilst compiling the spring integration source code. It looks like the missing of the dependencies jar files e.g. spring-aop 3.0, but I can not find those artifacts online after search maven or other repositories website.

    Code:
    http://repo2.maven.org/maven2/spring/spring-aop/ (1.x)
    http://repo2.maven.org/maven2/springframework/ (1.x)
    http://www.springsource.com/repository/app/bundle/detail;jsessionid=1C948BA396EFE577CB1CB851C640ACCC.jvm1?name=org.springframework.aop (2.5.x)
    The error thrown by maven
    Code:
    [INFO] ------------------------------------------------------------------------
    [ERROR] BUILD ERROR
    [INFO] ------------------------------------------------------------------------
    [INFO] Failed to resolve artifact.
    
    Missing:
    ----------
    1) org.springframework:spring-aop:jar:3.0.0.RC1
    
      Try downloading the file manually from the project website.
    
      Then, install it using the command: 
          mvn install:install-file -DgroupId=org.springframework -DartifactId=spring-aop -Dversion=3.0.0.RC1 -Dpackaging=jar -Dfile=/path/to/file
    
      Alternatively, if you host your own repository you can deploy the file there: 
          mvn deploy:deploy-file -DgroupId=org.springframework -DartifactId=spring-aop -Dversion=3.0.0.RC1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
    
      Path to dependency: 
      	1) org.springframework.integration:spring-integration-core:jar:2.0.0.BUILD-SNAPSHOT
      	2) org.springframework:spring-aop:jar:3.0.0.RC1
    
    2) org.springframework:spring-context:jar:3.0.0.RC1
    
      Try downloading the file manually from the project website.
    
      Then, install it using the command: 
          mvn install:install-file -DgroupId=org.springframework -DartifactId=spring-context -Dversion=3.0.0.RC1 -Dpackaging=jar -Dfile=/path/to/file
    
      Alternatively, if you host your own repository you can deploy the file there: 
          mvn deploy:deploy-file -DgroupId=org.springframework -DartifactId=spring-context -Dversion=3.0.0.RC1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
    
      Path to dependency: 
      	1) org.springframework.integration:spring-integration-core:jar:2.0.0.BUILD-SNAPSHOT
      	2) org.springframework:spring-context:jar:3.0.0.RC1
    
    3) org.springframework:spring-tx:jar:3.0.0.RC1
    
      Try downloading the file manually from the project website.
    
      Then, install it using the command: 
          mvn install:install-file -DgroupId=org.springframework -DartifactId=spring-tx -Dversion=3.0.0.RC1 -Dpackaging=jar -Dfile=/path/to/file
    
      Alternatively, if you host your own repository you can deploy the file there: 
          mvn deploy:deploy-file -DgroupId=org.springframework -DartifactId=spring-tx -Dversion=3.0.0.RC1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
    
      Path to dependency: 
      	1) org.springframework.integration:spring-integration-core:jar:2.0.0.BUILD-SNAPSHOT
      	2) org.springframework:spring-tx:jar:3.0.0.RC1
    It seems like my previous post about this question was missing. Not very sure whether it is deleted (posting to the wrong place) or I did not actually post to the forum (because I search the forum but can not find my previous question). So post it again. I appologize if this is not the right place to ask.

    Thanks for help.

    I appreciate it.

  • #2
    Spring Integration does not currently support Maven for *building* (only runtime resolution via its POMs). Instead, it uses spring-build (with support for OSGi bundle creation, etc.).

    The following should work:
    Code:
    svn co https://src.springsource.org/svn/spring-integration/trunk .
    cd build-spring-integration
    ant jar
    ant test
    ant package
    Be sure to set ANT_OPTS to have enough memory (something like "-XX:MaxPermSize=512m -Xmx512m" should work).

    Comment


    • #3
      Originally posted by Mark Fisher View Post
      Spring Integration does not currently support Maven for *building* (only runtime resolution via its POMs). Instead, it uses spring-build (with support for OSGi bundle creation, etc.).

      The following should work:
      Code:
      svn co https://src.springsource.org/svn/spring-integration/trunk .
      cd build-spring-integration
      ant jar
      ant test
      ant package
      Be sure to set ANT_OPTS to have enough memory (something like "-XX:MaxPermSize=512m -Xmx512m" should work).
      Thanks for this information. I am able to build the source using command e.g.
      Code:
      ant jar package
      I appreciate your help.

      Comment

      Working...
      X