Announcement Announcement Module
Collapse
No announcement yet.
Service Activator only reading one message at a time Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Service Activator only reading one message at a time

    Folks, I have my pipeline running smoothly, except that when it gets to the end, the service-activator appears to only be processing one message every second or so.

    I know that messages are piling up on the xDominObjectChannel, so i'm not sure why they're being pulled off so slowly.

    I'm sure i've got something configured wrong, but i can't tell what.

    Code:
    	<int:thread-pool-task-executor id="pool"
                                core-size="5"
                                max-size="25"
                                queue-capacity="20"
                                keep-alive-seconds="120" />
                                
    	<int:channel id="xDomainObjectChannel">
    		<int:queue capacity="10"/>
    	</int:channel>
    	
    
    	<int:service-activator ref="xMapperService" method="persistX" input-channel="xDomainObjectChannel">
    		<int:poller task-executor="pool" max-messages-per-poll="10">
    			<int:interval-trigger interval="50"/>
    		</int:poller>
    	</int:service-activator>
    Any ideas?

  • #2
    Can you share a sample project? I'm pretty sure that the messages are not piling up on the xDomainObjectChannel. You can check this if you turn on debug logging (you can see the messages being sent and received on the channel).

    Comment

    Working...
    X