Announcement Announcement Module
No announcement yet.
OSGi dependencies on Spring Framework Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • OSGi dependencies on Spring Framework

    Spring Integration (SI) depends on Spring Framework 2.5 and doesn't yet support Spring Framework 3.0.

    Meanwhile the committers are open to making minor changes so folks can start trying out some of the new Spring 3.0 features - like this issue here.

    This is very helpful, but OSGi manifests of even the most recent overnight builds still depend on Spring 2.5.6. This means we can't yet really deploy SI projects to OSGi servers running Spring 3.0, like Spring DM Server 2.0. For example, when I try to deploy a Spring-3-dependent project, I see error messages like this:

    Missing constraint: <Import-Package:; version="[2.5.6.A,3.0.0)"> in bundle <org.springframework.integration_1.0.3.CI-558>.

    Is this a fair summary of the current state of OSGi dependencies in SI? If so, if we really want to press ahead with trying out SI on DM Server 2.0 - for instance, to build HTTP gateways to integration services using the new Spring 3 REST support - is there anything we can do short of rebuilding the SI manifests by hand? This issue says "After 1.0.3 Spring Integration should depend on Spring 3.0 (RC)." When is that likely to happen?

    Last edited by jgaines; Jul 12th, 2009, 01:07 AM.

  • #2
    We are now feature-complete for 1.0.3 and actually the main thing we are completing prior to the release is more testing against Spring 3.0 and also running Spring Integration within an OSGi environment (by the way, the 1.0.3 release will include OSGi-enabled versions of a couple of the samples).

    So, to answer your first question: it's very likely that we will extend the range in our manifest headers to allow running with Spring 3.0 when using Spring Integration 1.0.3 (while 2.5.6 will remain the "official" version).

    To answer the second question: the SVN trunk will be switching to 2.0 development as soon as 1.0.3 goes out (this week), and Spring Integration 2.0 will actually require Spring 3.0.

    I hope that clarifies the situation. I've also just created this issue so you can watch progress and view/add any comments:

    If you have a chance to do some testing yourself and can share your experiences with us, that would be extremely helpful!



    • #3

      Excellent news, thanks very much!

      More than happy to report back whatever issues we stumble across in our testing.