Announcement Announcement Module
Collapse
No announcement yet.
Spring Integration 1.0.2 need Spring 2.5.6? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Integration 1.0.2 need Spring 2.5.6?

    HI all,

    I just using Spring Integration to replace my messy JavaMail code, i use spring 2.5 from netbeans 6.5, but i got error :

    Caused by: java.lang.NoSuchMethodError: org.springframework.beans.factory.support.BeanDefi nitionBuilder.genericBeanDefinition(Ljava/lang/StringLorg/springframework/beans/factory/support/BeanDefinitionBuilder;
    at org.springframework.integration.config.xml.Integra tionNamespaceHandler.registerDefaultConfiguringBea nFactoryPostProcessorIfNecessary(IntegrationNamesp aceHandler.java:63)
    at org.springframework.integration.config.xml.Integra tionNamespaceHandler.parse(IntegrationNamespaceHan dler.java:53)
    at org.springframework.beans.factory.xml.BeanDefiniti onParserDelegate.parseCustomElement(BeanDefinition ParserDelegate.java:1246)
    at org.springframework.beans.factory.xml.BeanDefiniti onParserDelegate.parseCustomElement(BeanDefinition ParserDelegate.java:1236)

    But when i switch to Spring 2.5.6 it solved, so can i get some confirmation that spring integration 1.0.2 depends on spring 2.5.6?

  • #2
    Yes, Spring Integration 1.0.2 requires 2.5.6. You can check either the ivy.xml or pom.xml to see the full list of dependencies and their versions.

    Comment

    Working...
    X