Announcement Announcement Module
Collapse
No announcement yet.
Using Spring Integration with jvm 1.4 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using Spring Integration with jvm 1.4

    Im getting a class version 49 , should be expected 48 when trying to embed the hello world example from spring integration into a existing java 1.4.2.11 weblogic application

    My question is if I build from source with the -source 1.4 option will I be able to use Spring Integration or is java 1.5 or higher required.

    Thanks

  • #2
    Not JVM 1.4 Compatable

    I found the answer elsewhere in the Forum.

    My current project contains a weblogic 8.1 sp5 server and i am able to use spring application contexts from inside the exposed api's . I can call and offer web services.

    Your presentation at Philly Tech sold me on Spring Integration.



    According to Mark Fisher Java 1.4 is not supported:

    Spring Integration relies heavily on Java 5 - including core language features (e.g. annotations and generics) as well as the Classes within java.util.concurrent. Based on that and the Spring Integration timeline, providing support for 1.4.2 just doesn't make sense.

    This is from (in the comments section):
    h t t p://blog.springsource.com/main/2007/12/21/spring-integration-samples/

    Comment


    • #3
      Spring Integration requires Java 5+

      Comment


      • #4
        Looks like our replies crossed paths there.

        Glad to hear you enjoyed the Philly ETE presentation!

        Comment

        Working...
        X