Announcement Announcement Module
Collapse
No announcement yet.
Dependency on Spring 2.5.6.A Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dependency on Spring 2.5.6.A

    Hi,

    I'm trying to use Spring Integration 1.0.1 (and the upcoming 1.0.2) in an OSGI environment (not Spring dm server) that has Spring 2.5.6 in it, and I'm hitting a problem because Spring Integration is dependent on Spring 2.5.6.A. Why is this? What is the difference between them?

    On the FAQ on the bundle repository it states

    "The "A" qualifier in the Spring Framework 2.5.4.A bundles is used to indicate "slightly newer than 2.5.4". This qualifier was added because SpringSource patched the Spring Framework 2.5.4 jars to make them OSGi compliant. Future Spring Framework releases will adopt the standard version numbering scheme described above and will be natively OSGi compliant. "

    so I'm not even sure why there is a 2.5.6.A version, and why something would have to be dependent on it.

    In effect this strict dependence on 2.5.6.A seems to be negating some the dynamic deployment benefits of OSGI. I could try updating the Spring jars here also, but it all seems like extra work that shouldn't be necessary.

    There's a thread on the spring batch forum: http://forum.springframework.org/showthread.php?t=67566 that implies there is two versions of this - one that only needs 2.5.6 - would this be possible in Spring Integration?

    Thanks for any help.

    Dave

  • #2
    If you are running in an OSGi environment, then you *do* need to depend on 2.5.6.A. In fact, the only difference between 2.5.6 in Maven central and 2.5.6.A in the SpringSource enterprise bundle repository is the manifest - specifically OSGi settings.

    That is why the Spring Integration manifests declare the dependency on 2.5.6.A whereas the pom.xml files depend on 2.5.6 (which is the version available in Maven central).

    Comment

    Working...
    X