Announcement Announcement Module
Collapse
No announcement yet.
SI officially compatible with Spring x.x? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SI officially compatible with Spring x.x?

    Hi,

    what versions of Spring is SI 1.0 officially compatible with?

  • #2
    I'm using it with spring-framework-2.5.6 without a problem.

    -mike

    Comment


    • #3
      thanks, that is the info I was looking for!

      Comment


      • #4
        By the way, if you ever have any questions about the "official" version for any of Spring Integration's dependencies, you can do one of two things:

        1) checkout the code from the SVN repository and look at the pom.xml or ivy.xml files in the root of each module.

        2) check the 'lib' directory to see the version that is included with the release. For example, here is the list of files in the 1.0.1 release's lib:
        Code:
        com.springsource.org.aopalliance-1.0.0.jar
        com.springsource.org.apache.commons.codec-1.3.0.jar
        com.springsource.org.apache.commons.collections-3.2.0.jar
        com.springsource.org.apache.commons.lang-2.1.0.jar
        com.springsource.org.apache.commons.logging-1.1.1.jar
        com.springsource.org.apache.ws.commons.schema-1.3.2.jar
        org.springframework.aop-2.5.6.A.jar
        org.springframework.beans-2.5.6.A.jar
        org.springframework.context-2.5.6.A.jar
        org.springframework.context.support-2.5.6.A.jar
        org.springframework.core-2.5.6.A.jar
        org.springframework.integration-1.0.1.RELEASE.jar
        org.springframework.integration.adapter-1.0.1.RELEASE.jar
        org.springframework.integration.ws-1.0.1.RELEASE.jar
        org.springframework.integration.xml-1.0.1.RELEASE.jar
        org.springframework.jms-2.5.6.A.jar
        org.springframework.oxm-1.5.5.A.jar
        org.springframework.security-2.0.4.A.jar
        org.springframework.transaction-2.5.6.A.jar
        org.springframework.web-2.5.6.A.jar
        org.springframework.ws-1.5.5.A.jar
        org.springframework.xml-1.5.5.A.jar

        Comment


        • #5
          3) check the SpringSource Enterprise Bundle repository: http://www.springsource.com/reposito...=1.0.1.RELEASE

          Comment

          Working...
          X