Announcement Announcement Module
Collapse
No announcement yet.
Unable to locate Spring NamespaceHandler when using Maven Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to locate Spring NamespaceHandler when using Maven

    Hi,
    I just upgraded to RC1 and tried the examples using Maven. Whenever the stream xsd (spring-integration-stream-1.0.xsd) is included in the namespace declaration, an exception occurs:

    Configuration problem: Unable to locate Spring NamespaceHandler for XML schema namespace

    In my dependencies, I have the core, adapter and ws.

    Code:
    	<dependencies>
    		<dependency>
    			<groupId>org.springframework.integration</groupId>
    			<artifactId>org.springframework.integration</artifactId>
    			<version>1.0.0.RC1</version>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework.integration</groupId>
    			<artifactId>
    				org.springframework.integration.adapter
    			</artifactId>
    			<version>1.0.0.RC1</version>
    		</dependency>
    		<dependency>
    			<groupId>org.springframework.integration</groupId>
    			<artifactId>
    				org.springframework.integration.ws
    			</artifactId>
    			<version>1.0.0.RC1</version>
    		</dependency>
    	</dependencies>
    I noticed in the jars that this stream xsd does not exist. Any help on how to resolve this?

    Thanks.

  • #2
    To use the 'stream' XSD, you also need to add the 'org.springframework.integration.stream' module to your dependencies.

    Comment


    • #3
      Hi Mark,
      Thanks! It worked.

      I never thought about 'org.springframework.integration.stream' module because I was only looking in the 'spring-integration-1.0.0.RC1/lib' folder and made it as a reference of my maven dependencies. Now I realized there's a 'dist' folder.

      Comment

      Working...
      X