Announcement Announcement Module
Collapse
No announcement yet.
Spring Integration JAVA Version Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Integration JAVA Version

    Hi,

    Can Springs Integration supports JAVA 1.4 version ?

    I am confused and not finding the documents any where..

    if yet all not possbile to use,is there any work around with we can achieve this ?

    Thanks,
    Murali

  • #2
    According to Mark Fisher Java 1.4 is not supported:

    Spring Integration relies heavily on Java 5 - including core language features (e.g. annotations and generics) as well as the Classes within java.util.concurrent. Based on that and the Spring Integration timeline, providing support for 1.4.2 just doesn't make sense.

    This is from (in the comments section):
    h t t p://blog.springsource.com/main/2007/12/21/spring-integration-samples/

    Comment


    • #3
      Thanks Mark for prompt response,i need to check other options now

      Comment


      • #4
        Murali,

        The thanks should go to 'fdurden' not me

        Out of curiosity, do you know how long you will likely be restricted to 1.4 - and what are the main driving forces for that?

        Cheers,
        Mark

        Comment

        Working...
        X