Announcement Announcement Module
Collapse
No announcement yet.
I get only the first message over the httpinvoker Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • I get only the first message over the httpinvoker

    Hello

    I created a little sample with httpinvoker-target and httpinvoker-source:

    Code and Log is in the attachment

    The mapping is not the problem, that seems to work.

    I get one message from the first call of the website, but on each additional call nothing happens

    Regards Pascal Nueesch

  • #2
    Hi,

    I have the same problem with RMI. Only the first call is received. After that, the receiver app seems to block, and the caller is waiting. If I stop the receiver, the caller restart processing, but of course, the receiver is know unavailable.

    Did you find a solution to your problem ?

    Comment


    • #3
      Is the calling application expecting a reply, or should it simply send the message and return immediately?

      If the latter, then you can set: expect-reply="false" in the gateway configuration.

      Comment


      • #4
        Hi,

        I'm having the exact same problem with a httpinvoker setup - first call goes through, the additional calls simply dont - did any of you guys find solutions or clues about the problem?

        Comment


        • #5
          Are you still having this problem after setting "expect-reply" to "false" ?

          Comment


          • #6
            hey mark,

            thanks for replying so fast, i'm not actually using spring integration, just a straight httpinoker setup so i don't think the expect-reply solution is relavent for me, i just searched httpinvoker on the forums and got trigger happy!

            that IS my problem though, any crazy chance you'd know why it's occuring? i'm off to bother the correct forum now....

            Comment

            Working...
            X