Announcement Announcement Module
Collapse
No announcement yet.
What JDK/Spring version are supported? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • What JDK/Spring version are supported?

    Hi,

    I didn't find the answer in the home web site and reference.

    Does it need Java 5?

  • #2
    Yes, Spring Integration does require Java 5 or later. I will be sure to make that more explicit in the reference manual before the next release.

    Thanks
    -Mark

    Comment


    • #3
      It appears Spring Integration requires Spring 2.5. Will it be possible to use with Spring 2.0 ?

      Thanks.

      Chris

      Comment


      • #4
        Chris,

        Spring 2.5+ will be required for Spring Integration 1.0. We will be taking advantage of new 2.5 features (e.g. extended annotation support and OSGi-compliance). Also, we would expect that by the time of the Spring Integration 1.0 final release, the only reason not to upgrade to Spring 2.5.x would be the need for Java 1.3 support - in which case Spring Integration would not be an option anyways.

        -Mark

        Comment

        Working...
        X