Announcement Announcement Module
Collapse
No announcement yet.
Spring Integration 2.2.0.RELEASE is available Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Integration 2.2.0.RELEASE is available

    Hi everybody,

    We are proud to announce that the GA version of Spring Integration 2.2.0 has been released! This substantial release addresses 333 Jiras and includes many new features, improvements and bugfixes. Please see the following announcement for further details:

    http://www.springsource.org/node/3756

    Cheers,

    Gunnar

  • #2
    What is the URL to the version 2.2 schema. I upgraded, but I start getting the exception below -


    org.springframework.beans.factory.parsing.BeanDefi nitionParsingException: Configuration problem: You cannot use prior versions of Spring Integration schemas with Spring Integration 2.2.

    Comment


    • #3
      Hi,

      Thanks for checking out 2.2! Regarding your issue - You need to either replace the old version in your XML context files with 2.2 version - e.g.:

      Code:
      http://www.springframework.org/schema/integration/spring-integration-2.2.xsd
      Even better would be to go version-less, e.g.:

      Code:
      http://www.springframework.org/schema/integration/spring-integration.xsd
      This approach will always use the latest available version.

      Cheers,

      Gunnar

      Comment


      • #4
        Thanks for your response. But the first link does not work. Not sure it is available yet. You can browse from the parent directory -


        http://www.springframework.org/schema/integration/

        Comment


        • #5
          We have fixed the links for the online schemas; however, please not that these are not used at runtime by Spring, the schemas within the jars are used instead. The online schemas are provided for documentation purposes.

          Also, please not that, for historical reasons, the version-less schema online is the 1.0 schema.

          However, we do recommend using the version-less schemas in config files.

          At runtime the framework resolves version-less schemas to the latest schema on the classpath (e.g. a version-less schema with Spring Integration 2.2.0.RELEASE will resolve to the ...-2.2.xsd schemas.

          For tooling, IDEs etc, they need to know how Spring resolves its schemas; with STS (or eclipse with the Spring tooling plugins), this is performed by enabling Spring Project Nature, as described in this post: http://forum.springsource.org/showth...ngs-And-Errors.

          Comment

          Working...
          X