Announcement Announcement Module
Collapse
No announcement yet.
Spring integration and Spring framework 3.1.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring integration and Spring framework 3.1.1

    I am very interested in using spring integration and migrating from my use of JmsTemplate.

    I downloaded the samples and am trying to run the JMS project after changing to spring 3.1.1 in the pom. When i try to run it, i get Unable to locate Spring NamespaceHandler for XML schema namespace [http://www.springframework.org/schema/integration/jms]. Since this is version independent, what is the issue here?
    Any help would be appreciated.

  • #2
    What IDE? If STS, try the steps described here... http://forum.springsource.org/showth...ngs-And-Errors

    Comment


    • #3
      using intellij.

      Comment


      • #4
        just to clarify i made a test project and am running a simple test thru maven with same error

        Comment


        • #5
          Hello

          Have you got spring-integration-jms.jar in your classpath?
          Miracles do not happen...

          Can you show here your pom.xml & a bit of StackTrace?
          Last edited by Artem Bilan; May 31st, 2012, 10:37 AM.

          Comment


          • #6
            well, that does it but i am confused -- why was this commented out in the the pom of the samples? That was the reason i left it off...

            Comment

            Working...
            X