Announcement Announcement Module
Collapse
No announcement yet.
spring-integration-file 2.1.1.RELEASE OSGi MANIFEST issue Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spring-integration-file 2.1.1.RELEASE OSGi MANIFEST issue

    Hi,
    There seems to be an issue with import package version ranges in 2.1.1.RELEASE of spring-integration-file bundle, you will notice in the following snippet from the MANIFEST.MF that the import version ranges for other spring integration packages exclude 2.1.1 which seems to me to be wrong (especially since the maven dependencies contradict this). This renders the spring-integration-file component unusable with 2.1.1.RELEASE in an OSGi context.

    <snip>
    Import-Package: org.apache.commons.logging;version="[1.1.1, 2.0.0)",or
    g.springframework.beans;version="[3.0.5, 4.0.0)",org.springframework.
    beans.factory;version="[3.0.5, 4.0.0)",org.springframework.beans.fact
    ory.config;version="[3.0.5, 4.0.0)",org.springframework.beans.factory
    .support;version="[3.0.5, 4.0.0)",org.springframework.beans.factory.x
    ml;version="[3.0.5, 4.0.0)",org.springframework.expression;version="[
    3.0.5, 4.0.0)",org.springframework.expression.common;vers ion="[3.0.5,
    4.0.0)",org.springframework.expression.spel.standa rd;version="[3.0.5
    , 4.0.0)",org.springframework.expression.spel.suppor t;version="[3.0.5
    , 4.0.0)",org.springframework.integration;version="[2.1.0, 2.1.1)",or
    g.springframework.integration.config;version="[2.1.0, 2.1.1)",org.spr
    ingframework.integration.config.xml;version="[2.1.0, 2.1.1)",org.spri
    ngframework.integration.context;version="[2.1.0, 2.1.1)",org.springfr
    amework.integration.core;version="[2.1.0, 2.1.1)",org.springframework
    .integration.endpoint;version="[2.1.0, 2.1.1)",org.springframework.in
    tegration.handler;version="[2.1.0, 2.1.1)",org.springframework.integr
    ation.support;version="[2.1.0, 2.1.1)",org.springframework.integratio
    n.transformer;version="[2.1.0, 2.1.1)",org.springframework.integratio
    n.util;version="[2.1.0, 2.1.1)",org.springframework.util;version="[3.
    0.5, 4.0.0)",org.springframework.util.xml;version="[3.0.5, 4.0.0)",or
    g.w3c.dom;version="0"
    </snip>

    I didn't see any issues reported in JIRA, anyone aware of this ?

    Thanks,
    Declan
Working...
X