Announcement Announcement Module
Collapse
No announcement yet.
Avoiding STS Bogus Warnings And Errors Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avoiding STS Bogus Warnings And Errors

    If you are seeing strange errors and/or warnings in your Spring Integration application context files, you likely have an old version of the schema cached in STS.

    Try the following

    Window | Preferences

    Type 'cache' in the filter; in General | Network Connections | Cache, click 'Remove All'.

    Also, be sure to enable 'Spring Project Nature' on the project (right click Spring Tools...).

    Finally, ensure that 'Load NamespaceHandlers and XSDs from project's classpath' is checked in

    Window | Preferences | Spring | Beans Support | Namespaces

    and is not overridden in the project's properties.

    You may need to clean all projects after making these changes.

  • #2
    Another thing to try is to create a new workspace and re-import the project(s).

    I just spent a few hours trying to resolve an issue with my installation of the basic/mail sample (https://github.com/SpringSource/spri...ration-samples) where, no matter what I tried, STS kept validating against the 1.0 schema instead of 2.2. I could explicitly use the 2.2 schema and all was well, but using the unversioned schema (which is our recommendation) just wouldn't work. The project ran ok, the errors were just in the editor.

    In the end, creating a new STS workspace and re-importing the projects fixed the problem.

    I suspect there was some corruption, somewhere, in the workspace .metadata directory.

    So, if all else fails, try creating a new workspace.
    Last edited by Gary Russell; Aug 24th, 2012, 05:48 PM.

    Comment


    • #3
      Hi Gary,

      I cannot import spring-intagration as gradle project. I asked guys on STS forum but without any feedback so far. Here is the link to this issue: http://forum.springsource.org/showth...gradle-project

      Any help is really appreciated.

      Thanks,
      Krzysztof

      Comment


      • #4
        I've not tried that; I use

        ./gradlew cleanEclipse eclipse

        on the command line, and then 'Import Existing...'

        Comment


        • #5
          Hi Gary,

          It was my mistake, some time ago I created "spring-integration-test" project in the default workspace and have forgotten about it. The same name is used in spring-integration and that's way I got this name clash during the import. Anyway thanks for your suggestion.

          Best,
          Krzysztof

          Comment

          Working...
          X