Announcement Announcement Module
Collapse
No announcement yet.
SFTP failed to copy file 4: Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SFTP failed to copy file 4:

    Hello !
    Problem using SFTP outbound adpater, the stacktrace is provided in an attachment.
    My springconfig will be attached to this post. Thanks in advance.

    Regrads,

    Daniel

  • #2
    Can you please describe the problem more thoroughly, and what you have done to diagnose it.
    What are we looking for in the stacktrace and config file you've posted?
    How do you know its not a problem in com.jcraft.jsch.ChannelSftp?
    What version of Spring Integration are you using?

    Comment


    • #3
      RE: SFTP failed to copy file 4:

      Ok. Well as in the spring context file, the flow is all about producing an invoice
      xml file, for sweden and finland. The part that files as i understand the error message is the copy of the file.

      I had a look in the class SFTPSession seems this class logs the
      failure. I am using spring integration 2.0 but tried even 2.0.5 and got the same result.

      I assume it is in spring integration but i am not 100 % sure.

      Thanks in advance.

      Regards,

      Daniel

      Comment


      • #4
        All i see is failure to copy file. There could be hundreds of reason why this might be happening (JSCH is not good with their exception messages), but without more information discussing any them would be a pure speculation.
        As far as configuration, I would suggest to slim it down to the point where it only represents enough to reproduce the error.

        Comment

        Working...
        X