Announcement Announcement Module
Collapse
No announcement yet.
MongoDB: Repository delete() not working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Funny enough, this bug still bites me. Downloaded 1.0.0M2 binaries and replaced data-commons with the nightly build directly from bamboo.

    Based on this release i was able to create and query documents. But removing or findAndRemoving still failed for me.

    All jar artifacts have been created around Sat Apr 09 18:57.

    Probably i should decide to finally switch to maven for dependency management. Any recommendation on a Maven plugin for Eclipse?

    Comment


    • #17
      Hi,

      i'm using "spring-data-mongodb" version "1.0.0.RC1".
      I discovered, deleting with "mongoTemplate.remove(Object object)" doesnt delete the object from the DB, but "mongoTemplate.remove(Object object, String collectionName)" does.

      Can anyone confirm this? I would say that this is a bug, isn't it?

      Comment


      • #18
        Would you mind trying 1.0.1.RELEASE?

        Comment


        • #19
          Thank you very much, Oliver.

          I didn't notice that there is a release version. I only grabbed the maven dependency snippet on the SpringData MongoDB website which still references spring-data-mongodb version 1.0.0.RC1. I expected the site to be up to date. :-)

          <dependency>
          <groupId>org.springframework.data</groupId>
          <artifactId>spring-data-mongodb</artifactId>
          <version>1.0.0.RC1</version>
          </dependency>

          Comment


          • #20
            I'm having the same problem. I've upgraded to spring-data-mongodb 1.0.1.RELEASE. I can't get it to remove an object from the collection. I've tried both mongoTemplate.findAndRemove() methods. They are returning the right object, but the object is still in the collection. I've also tried all 4 mongoTemplate.remove() methods, but the object is still in the collection. Any ideas? Thanks!

            Comment


            • #21
              Nevermind. I got it to work. It wasn't using the right jars. Stupid programmer error as usual.

              Comment

              Working...
              X