Announcement Announcement Module
Collapse
No announcement yet.
Missing schema /data/graph/ Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing schema /data/graph/

    Hey guys,

    i tried the new data-graph-neo4j-m04 release but experienced some issues during creating a context.xml. Seems like the schema-file (http://www.springframework.org/schema/data/graph http://www.springframework.org/schem...agraph-1.0.xsd) is missing.
    Am i wrong?!

    greetings
    Earl

  • #2
    Earl,

    thanks for pointing that out. Does your context work anyway? It should.

    I asked the responsible people at springsource some while ago to upload the xsd but it seems to have gotten lost, I just sent an reminder email.

    Thanks

    Michael

    Comment


    • #3
      Hi Michael,

      actually it doesn't. My Eclipse always complains about this tag statement.
      <datagraph:config storeDirectory="path/to/my/neo-store" graphDatabaseService="graphDatabaseService"/>.

      Another issue i experience is the notification that my node entities which are correctly annotated with @NodeEntity are not an extending class of NodeBacked. I can't resolve this one. Can you help me out?

      My current implementation uses neo4j 1.3m04 and spring-data-graph for the aforementioned neo4j version.

      Thanks in advance.
      Earl

      Comment


      • #4
        Earl,

        do you have the xml namespace reference in the file header?

        Like:
        Code:
        <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
        <beans xmlns="http://www.springframework.org/schema/beans"
          xmlns:context="http://www.springframework.org/schema/context"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            xmlns:datagraph="http://www.springframework.org/schema/data/graph"
          xsi:schemaLocation="
            http://www.springframework.org/schema/beans 
            http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
            http://www.springframework.org/schema/context 
            http://www.springframework.org/schema/context/spring-context-3.0.xsd
            http://www.springframework.org/schema/data/graph 
            http://www.springframework.org/schema/data/graph/datagraph-1.0.xsd
            ">
        
            <context:annotation-config/>
            <datagraph:config storeDirectory="target/config-test"/>
        IntelliJ idea allows you to "ignore" the missing schema and works fine afterwards. Also if you built/run it with the maven commandline or IDE integration it should work fine.

        Regarding your entities. There were some issues that we just recently resolved with the aspectj team, the AJDT addon for eclipse has to be the latest Milestone (1.6.11.M2)

        The interfaces are introduced by the aspect.

        Try to set your update site for AJDT to: http://download.eclipse.org/tools/ajdt/36/dev/update

        Should help.

        Thanks for reporting these things

        Michael

        Comment


        • #5
          I have added the schema to the www.springframework.org site now.

          Comment


          • #6
            problem still persists

            Hi,

            I have taken all the steps proposed in the above posts but i do see the compiler errors in the editor. I am using the IMDB example for my exercise.

            My IDE details

            STS 2.6.0.RELEASE

            AspectJ
            Version: 2.1.3.e36x-20110427-1400
            AspectJ version: 1.6.12.20110427140000

            Any other solutions, please?

            Thank you.

            Comment


            • #7
              Thanks for pointing that out and providing the details.

              Sorry, there is a minor error in the AJDT plugin left, the AspectJ team already works on fixing that one (which is just a display error). They promised it for next week.

              Thanks

              Michael

              Comment

              Working...
              X