Announcement Announcement Module
Collapse
No announcement yet.
beginner trying to run the cineasts demo Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • beginner trying to run the cineasts demo

    hi.. what are the steps to get the cineasts demo project into eclipse and then working? i am sorry, but I don't understand what i am supposed to be doing.

    do i download the zip from github, find the examples/cineasts folder and then import as existing maven project in eclipse. if so, what next so that i can see it running? does it use tomcat or another server, and if so, what do i need to do to get that running.

    sorry i am a complete beginner but i want to get to learn spring data neo4j but for a complete beginner there is a lot to learn! (java, maven, spring mvc, hibernate, aop, git, etc etc etc!!). thanks for any help and guidance..

    any other books/tutorials out there - especially video - with step by step guides for beginners?

  • #2
    ok so i downloaded the cineasts examples from github as a zip from here:
    https://github.com/SpringSource/spring-data-neo4j

    i downloaded everything but the examples is actually located here:
    https://github.com/SpringSource/spri...mples/cineasts

    once downloaded i copied the cineasts folder to a convenient location
    in eclipse i went to file->import->maven->Existing Maven Projects
    then i browsed to the location of the cineasts folder i sorted previously
    then eclipse imports the project and resolves all the dependencies as per the pom.xml (which takes

    a while)
    to run, i right-clicked on the project root folder (cineasts) in the package explorer in eclipse
    then i selected run as->maven build
    in the run configurations dialogue that popped up i put:
    jetty:run
    in the Goals: section
    then i ran

    as specified i tried to navigate to http://localhost:8080/populate in a browser
    unfortunately i got the following error:
    org.apache.jasper.JasperException: java.err.nojdk

    i have java jdk 1.7 installed so instead of using the JRE System Library (JavaSE-1.6) which was how

    it was set up by default in eclipse, i changed it by right-clicking on the project root folder

    (cineasts) in the package explorer and then selecting properties

    then i selected java build path and edited the JRE System Library to point to my Java 1.7 JDK installation..

    when i now ran the project using run as->cineasts i got the following error when navigating to
    http://localhost:8080/populate

    nested exception is java.lang.IllegalArgumentException New value elements must be class

    org.neo4j.cineasts.domain.Director

    this is where i am stuck..
    thanks

    Comment

    Working...
    X