Announcement Announcement Module
Collapse
No announcement yet.
how to use spring-data-mongdb-1.2.0 & spring-data-jpa1.1.0 in one project? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • how to use spring-data-mongdb-1.2.0 & spring-data-jpa1.1.0 in one project?

    I have used spring-data-jpa1.1.0 for a while.
    recently I am trying to add spring-data-mongodb1.2.0 into my existing project.

    After building the project, I try to start the tomcat, it throws exception below (with spring-data-commons-1.3.2):

    Code:
    Caused by: java.lang.ClassNotFoundException: org.springframework.data.repository.config.RepositoryConfigurationExtension
    Then i update the dependent jar from spring-data-commons-1.3.2 to spring-data-commons-1.5.0,
    there is another exception thrown:
    Code:
    Caused by: org.xml.sax.SAXParseException: src-resolve: Cannot resolve the name 'repository:repository' to a(n) 'type definition' component.

    anyone could help?

  • #2
    Make sure you combine modules of the same release train. E.g. for the latest Arora release it's SD Commons 1.5, SD JPA 1.3 and SD MongoDB 1.2 as indicated here [0] and here [1].

    [0] http://www.springsource.org/node/3811
    [1] https://github.com/SpringSource/spri...se-Train-Arora

    Comment


    • #3
      got it, it works now.
      thanks a lot.

      Comment

      Working...
      X