Announcement Announcement Module
Collapse
No announcement yet.
[Neo4j] spring-data-neo4j-2.0.1.RELEASE maven issue Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Neo4j] spring-data-neo4j-2.0.1.RELEASE maven issue

    Hi all,
    I have just started to use neo4j with Spring data. I am using maven and POM file. I use for Sring Data neo4j version 2.0.1.RELEASE, for Spring Framework itself version 3.1.2.RELAESE.
    Th epom file looks following:
    Code:
    <properties>
            <org.springframework.version>3.1.2.RELEASE</org.springframework.version>
            <spring-data-neo4j.version>2.0.1.RELEASE</spring-data-neo4j.version>
    ................
    
    <dependency>
                <groupId>org.springframework</groupId>
                <artifactId>spring-core</artifactId>
                <version>${org.springframework.version}</version>
            </dependency>
    
    ........
    <dependency>
                <groupId>org.springframework.data</groupId>
                <artifactId>spring-data-neo4j</artifactId>
                <version>${spring-data-neo4j.version}</version>
                <exclusions>
                    <exclusion>
                        <groupId>org.hibernate.javax.persistence</groupId>
                        <artifactId>hibernate-jpa-2.0-api</artifactId>
                    </exclusion>
                    <exclusion>
                        <groupId>org.neo4j</groupId>
                        <artifactId>neo4j-spatial</artifactId>                    
                    </exclusion>
                </exclusions>
    
            </dependency>
    If I start the build process maven spoils my local repository with downloading lot of Spring Frameworks versions (it in fact downloads almost all artefacts in the official maven repository). If I comment the dependency artefact for spring-data-neo4j, the maven downloads only the right Spring Framework - 3.1.2.RELEASE.

    I have been using Spring for a few projects and no such issue yet.

    Any advice what I am doing wrong ?

    Thanks Mitko

  • #2
    Mitko,

    Please use SDN version 2.1.0.

    Regards,

    Lasse

    Comment


    • #3
      Thanks Lasse,

      I have already tried 2.1.0.RC4 and it now works fine.

      Regards

      Mitko

      Comment

      Working...
      X