Announcement Announcement Module
Collapse
No announcement yet.
[Neo4j] Impermanet database stored in filesystem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Neo4j] Impermanet database stored in filesystem

    Hey everyone!

    there's a problem with my Neo4j-Test-Setup-Environment and the org.neo4j.test.ImpermanentGraphDatabase...
    I have a class, TestGraphPopulator, for setting up some dummy data for my unit tests.

    Because of adding, delte, update operations I populate the graph in every test case in init-method annotated via @Before.

    But there is some really strange behavior sometimes. Some of my test fail, because there are more or less entities as expected. In a second, or third, etc. run, everything is fine, ..or not.

    AND, in my /target directory of my project, there is a folder \target\test-data\impermanent-db with all the Neo4J database data...

    I'm not sure of what my problem results of, but should NOT ImpermanentGraphDatabase only reside in memory??
    For me, it looks like a bug, could anyone share some experience?? This seems very important to me, and maybe others...

    Thanks a lot in advance!
    Markus

    P.S.:
    Neo4J 1.8, Spring Data Neo4J 2.1 ..
    Last edited by markuse1501; Nov 6th, 2012, 12:37 PM.

  • #2
    Markus,

    We are aware of it: https://github.com/neo4j/community/i...tgraphdatabase

    It should still be fully functional though, if you can reproduce this consistently please raise an issue on github.

    Regards,

    Lasse

    Comment


    • #3
      Thank you Lasse!

      Comment

      Working...
      X