Announcement Announcement Module
Collapse
No announcement yet.
Neo4J aspectj-maven-plugin error when using source/target 1.7 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Neo4J aspectj-maven-plugin error when using source/target 1.7

    I'm trying to use the Spring Data Neo4j Advanced Mapping features - and I get an error on [aspectj:compile] when I change the source and target to 1.7 in the aspectj-maven-plugin. (Using the plugin as described in the Spring Data Book).

    Code:
    can't override java.lang.Object org.springframework.data.neo4j.aspects.core.GraphBacked.getPersistentState() with org.neo4j.graphdb.Relationship org.springframework.data.neo4j.aspects.core.RelationshipBacked.getPersistentState() return types don't match
    It complies fine if I leave the source and target at 1.6. Although since I'm using 1.7 - I'm not sure of the outcome yet... Is this something to worry about?

    M
Working...
X