Announcement Announcement Module
Collapse
No announcement yet.
Problem with dependencies for mongodb 1.0.2.RELEASE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with dependencies for mongodb 1.0.2.RELEASE

    Hi all,

    I have a problem building my project including a dep to spring-data-mongodb 1.0.2.RELEASE. That artifact defines a version range and tries to 'download' a snapshot version of spring-tx (org.springframework:spring-tx:jar:3.2.0.BUILD-20120909.200117-267) among others. I can't find that artifact in the repo (and neither can my Artifactory...). Anyone else experiencing the same problem? Any hints will be most appreciated!

    br
    /svante

  • #2
    Make sure you have the right repositories defined. If you only have Maven central declared or our SpringSource artifactory (http://repo.springsource.org/libs-release) then the Maven dependency resolution will not refer to snapshot versions. It only will if you declare a snapshot repository like http://repo.springsource.org/libs-snapshot.

    Comment

    Working...
    X