Announcement Announcement Module
Collapse
No announcement yet.
Getting Neo4j cypher queries to work in java GraphRepository Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Is your index really called auto_index_node? The default name is "User" if it is in the user class.

    Also your regexp is wrong:

    "*.termSearch*." must be ".*termSearch.*" dot-star, dot stands for any character and star for zero to n occurrences.

    Comment


    • #17
      Originally posted by MichaelHunger View Post
      Is your index really called auto_index_node? The default name is "User" if it is in the user class.

      Also your regexp is wrong:

      "*.termSearch*." must be ".*termSearch.*" dot-star, dot stands for any character and star for zero to n occurrences.
      Pedro dixit: It's similar to this, i don't remember exact code now

      this was an example, no exact code, intended as pseudo-code. Both consultants work fine in webadmin, but the first example no work fine in SDN.

      Pseudo-code

      START user=node:index(idUser={0})
      MATCH user-[rel]-car
      WHERE car.model =~ {1} or car.color =~{2}
      RETURN distinct(car)

      where params {1} and {2} is a concated string with termSearch and regular expressions (solution previous post)

      the new query it's similar to this:

      START user=node:index_user(idUser={0}), car=node:index_car({1})
      MATCH user-[rel]-car
      RETURN distinct(car)


      where param {1} is a concated string with lucene fields on index_car (lucene) and regular exprression

      Regards
      Last edited by pedro.abalo; Jan 8th, 2013, 03:38 AM.

      Comment


      • #18
        Pedro,

        what does your repository method look like (I assume you use an repository for the query).
        Would it be possible for you to share a project with a failing unit test that shows the problem?

        Thanks a lot

        Michael

        Comment

        Working...
        X