Announcement Announcement Module
Collapse
No announcement yet.
Using neo4j version 1.7.1 fails Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using neo4j version 1.7.1 fails

    I have a working sample project. This uses neo4j 1.7 with spring-data-neo4j.version 2.1.0.RC1. As I was looking at how to install Neoclipse, I saw that the current version of neo4j is 1.7.1. So I updated the version in my pom, and restarted. This fails with a very large stack trace found here: http://pastebin.com/TQ7zV8bx

    I can revert back to 1.7, and it works. I've tried deleting the data graph, to no avail. I can also find no info on version compatabilities between the to pieces.

    Any help appreciated.

  • #2
    Looking at your stack trace, you should always go to the bottom and find the root cause by

    Caused by: java.lang.NoSuchMethodError: org.neo4j.kernel.impl.transaction.SpringTransactio nManager.<init>(Lorg/neo4j/graphdb/GraphDatabaseServiceV
    at org.springframework.data.neo4j.config.Neo4jConfigu ration.createJtaTransactionManager(Neo4jConfigurat ion.java:245)
    at

    What that says to me is the Spring Data 2.1.0.RC is calling a method on Neo4j 1.7.1 that doesn't exist in 1.7.1, but looks like it exists in 1.7

    That is my guess.

    Which version of Neo4J does Spring Data 2.1.0.RC say it supports up to?

    Mark

    Comment


    • #3
      treaves,

      This is a known issue and a fix is imminent: https://jira.springsource.org/browse/DATAGRAPH-255

      Regards,

      Lasse

      Comment

      Working...
      X