Announcement Announcement Module
Collapse
No announcement yet.
Uses Violation on org.springframework.data.neo4j Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Uses Violation on org.springframework.data.neo4j

    Hi all,

    My first post:

    I am installing a web service on the Virgo server. I'm currently attempting to use the neo4j-osgi bundle. I'm getting the following uses violations:


    Code:
    Resolver report:
            Uses violation: <Import-Package: org.neo4j.kernel.impl.persistence; version="0.0.0"> in bundle <org.springframework.data.neo4j_1.1.0.RELEASE[1316357883861]>
                 Resolver reported uses conflict for import
            Uses violation: <Import-Package: org.neo4j.index.impl.lucene; version="0.0.0"> in bundle <org.springframework.data.neo4j_1.1.0.RELEASE[1316357883861]>
                 Resolver reported uses conflict for import
            Uses violation: <Import-Package: org.neo4j.kernel; version="0.0.0"> in bundle <org.springframework.data.neo4j_1.1.0.RELEASE[1316357883861]>
                 Resolver reported uses conflict for import
            Uses violation: <Import-Package: org.neo4j.kernel.impl.transaction; version="0.0.0"> in bundle <org.springframework.data.neo4j_1.1.0.RELEASE[1316357883861]>
                 Resolver reported uses conflict for import
            Uses violation: <Import-Package: org.neo4j.kernel.impl.nioneo.store; version="0.0.0"> in bundle <org.springframework.data.neo4j_1.1.0.RELEASE[1316357883861]>
                 Resolver reported uses conflict for import
            Uses violation: <Import-Package: org.neo4j.kernel.impl.core; version="0.0.0"> in bundle <org.springframework.data.neo4j_1.1.0.RELEASE[1316357883861]>
                 Resolver reported uses conflict for import
    The thing is, there is only one single instance of each neo4j package present in the repository. I understand that these kind of uses conflict appear when differing versions of a given package are exported. This is not the case here. I am at a loss to explain the above.

    How can I resolve this? Suggestions or outright answers are welcome. I would be happy to supply additional info.

    Regards,

    Wim.
Working...
X