Announcement Announcement Module
Collapse
No announcement yet.
Neo4j Spring Data Graph Dependency: PagingAndSortingRepository Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Neo4j Spring Data Graph Dependency: PagingAndSortingRepository

    I'm getting this message when trying to use the Neo4j data graph.

    "The type org.springframework.data.repository.PagingAndSorti ngRepository cannot be resolved. It is indirectly referenced from required .class files"

    Is there another Jar I need to download. I've been searching for where I need to download this for hours.

  • #2
    What version of SDG are you using, i.e. what is in your pom.xml ?

    I think the problem is that there is a dependency on spring-data-commons which got some repackaging. So we should figure out what's wrong there.

    Could you issue mvn dependency:tree on the command-line and paste the output in this thread.

    Thanks

    Michael

    Comment

    Working...
    X