Announcement Announcement Module
No announcement yet.
where is roperty Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • where is roperty

    doesn't exists in

    java.lang.NoClassDefFoundError: org/springframework/data/mapping/model/PersistentProperty
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(
    at org.ironrhino.core.remoting.impl.AbstractServiceRe gistry.init(
    at org.ironrhino.core.remoting.impl.AbstractServiceRe gistry.postProcessBeanFactory(AbstractServiceRegis
    at ationContext.invokeBeanFactoryPostProcessors(Abstr
    at ationContext.invokeBeanFactoryPostProcessors(Abstr
    at ationContext.refresh(AbstractApplicationContext.ja va:407)
    at org.springframework.web.context.ContextLoader.crea teWebApplicationContext(
    at org.springframework.web.context.ContextLoader.init WebApplicationContext(
    at org.springframework.web.context.ContextLoaderListe ner.contextInitialized( 47)
    at org.apache.catalina.core.StandardContext.listenerS tart(
    at org.apache.catalina.core.StandardContext$
    at org.apache.catalina.core.StandardContext$
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu
    at a:138)
    at java.util.concurrent.ThreadPoolExecutor$ Task(
    at java.util.concurrent.ThreadPoolExecutor$ (
    Caused by: java.lang.ClassNotFoundException: roperty
    at org.apache.catalina.loader.WebappClassLoader.loadC lass(
    at org.apache.catalina.loader.WebappClassLoader.loadC lass(
    ... 18 more

  • #2
    I had the same problem when using spring-data-commons-core-1.1.0.M2 and spring-data-mongodb-1.0.0.M3. I found the cause of the problem to be with PersistentProperty having been moved to the package. The class making the reference is MongoPersistentProperty. I just changed the dependency back to spring-data-commons-core-1.1.0.M1 and all is well for now.


    • #3
      I am experience the same issue however I attempted your solution of changing to spring-data-commons-core-1.1.0.M1 and it still produces the exception.


      • #4
        Have you tried searching for the PersistentProperty class in your classpath in order to determine its package? If you are using Eclipse just search for types having the name PersistentProperty in you project or workspace.

        I have sping-data-commons-core-1.1.0.M1 and spring-data-mongodb-1.0.0.M3 in my classpath. A search for PersistentProperty results in two dependents MongoPersistentProperty and MongoPersistentEntityIndexCreator.


        • #5
          Spring - PersistentProperty issue

          Hello there,

          I'm up against the same problem since last 2 days. Could you please let me know if you found any solution? Thanks.