Announcement Announcement Module
Collapse
No announcement yet.
Paged results: no matching response control found Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Paged results: no matching response control found

    Hi everyone,

    I'm having trouble setting up a paged search: apparently a response control is missing but I can't figure out how to create/use it...

    here is my code:

    Code:
    SearchControls searchControls = new SearchControls();
    
    searchControls.setCountLimit(resultsLimit);
    
    searchControls.setSearchScope(SearchControls.SUBTREE_SCOPE);
    		
    CollectingNameClassPairCallbackHandler handler = new ContextMapperCallbackHandler(cm);
    		
    PagedResultsDirContextProcessor requestControl = new  PagedResultsDirContextProcessor(3);
    
    ldapTemplate.search(root, filter.encode(), searchControls, handler, requestControl);
    	    
    return handler.getList();

    The request works just fine without the paged results dir context processor, otherwise it returns me 0 results and this error in the logs:

    "No matching response control found for paged results - looking for 'class javax.naming.ldap.PagedResultsResponseControl"


    Could anybody help me?


    Thanks a lot

  • #2
    What LDAP server are you using? Did you make sure that the LDAP server you are using
    supports paged results?

    Comment


    • #3
      Hi Bvar,

      I'm not a 10% sure but another application appears to do the same thing, so I guess the server implements paged search.

      Anyway, I feel like the server isn't the problem here: I checked into the logs and there was no trace of my connections, so apparently they died before even reaching the server.

      That's why I think the problem comes from the code: don't you notice anything wrong with it?

      Comment


      • #4
        Did you solve this issue?
        I have the same problem and I've tried a lot of things to solve it, but with no luck.

        Comment


        • #5
          Originally posted by ovedwish View Post
          Did you solve this issue?
          I have the same problem and I've tried a lot of things to solve it, but with no luck.
          Did you resolve this now?

          Comment


          • #6
            The problem occured in my environment due to a bug in Jboss 7, in its earlier stages. It was now solved, so I didn't encounter this issue again.

            What environment are you working on?

            Do you have more information on the exact error/exception?

            I'll be happy to help.

            Oved

            Comment


            • #7
              The details are here, please help

              http://forum.springsource.org/showth...-query-on-LDAP

              Comment

              Working...
              X