Announcement Announcement Module
Collapse
No announcement yet.
ldap 1.3.0 with spring 3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ldap 1.3.0 with spring 3

    Hi,

    my bundle org.springframework.ldap(1.3.0) from
    http://www.springsource.com/repository/app/
    imports org.springframework.beans with [2.5.5, 3.0.0).

    This fails for spring 3.0.1.
    Is org.springframework.ldap not supported anymore?

    Ingo

  • #2
    Are you saying that it worked for 3.0.0? That's would be surprising, since [2.5.5, 3.0.0) means 2.5.5 <= x < 3.0.0.

    I'm afraid I don't know who has OSGi-ified the manifest and added Spring LDAP to the repo.

    Is org.springframework.ldap not supported anymore?
    Not sure what you mean here. We have tested Spring LDAP with Spring 3.0.x, and that certainly works.
    Last edited by ulsa; Mar 25th, 2010, 09:43 AM.

    Comment


    • #3
      Hi,

      no, it works with Spring 2.5, not 3.0.
      That's my problem at the moment.

      I think http://www.springsource.com/repository/app/
      is an official spring repository.
      I find there all other spring projects. Spring LDAP is the only exception, that's why I was wondering if Spring LDAP isn't supported anymore.

      Comment


      • #4
        I meant that we have tested Spring LDAP with Spring 3.0 in a standard web container. We have not performed any tests in OSGi.

        We (in Spring LDAP) are not affiliated with SpringSource, so we can't say anything about their repository or what's in it. Sorry.

        Comment


        • #5
          so could an own osgi bundle of spring ldap be a solution?
          i'm wondering if there is a difference, using spring ldap with spring 3.0.x or use it within spring dm server for example.

          Comment

          Working...
          X