Announcement Announcement Module
Collapse
No announcement yet.
backporting to jdk1.3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • backporting to jdk1.3

    I know that one of the stated requirements of Spring-LDAP is JDK1.4 (Java 4). That being said, I am wondering if there is any technical reason not to be able to backport the library to JDK1.3, which is the lowest common denominator for much of the rest of Spring at runtime.

    I have done some analysis and it looks like most of the 1.4 dependencies are on the java.util.regex package, or on things like String.split(String). I also see some dependencies on java.net.URI.

    Like many people I have a WebSphere dependency (kindof feels like an addiction right now...), that I am trying to break away from, but am not able to at this time. I also have a bunch of code that uses Spring-LDAP that needs to run in that environment.

    Any information/thoughts would be appreciated. It is likely that I am going to jump in and try to make a back port.

    I am just curious if I am wasting my time, and wondering if anyone else would be interested in the outcome.


    -Brian

    Brian S. Lloyd-Newberry
    http://newbebweb.blogspot.com

  • #2
    We appreciate you taking the time to investigate this. We're definitely interested in the outcome.

    Here are some compatibility issues that we know of:
    1. Support for LDAPS protocol came in 1.4.2.
    2. Connection pooling came in 1.4.1.
    3. Support for multiple space-separated URLs came in 1.4.1. A URL that contains spaces works on 1.4.0 and earlier, but will stop working on 1.4.1+. Text after the space is interpreted as the next URL.
    4. Support for TLS, as well as some other security support, came in 1.4.0.
    5. Before 1.4.2, default port number is 389 regardless of whether SSL is used.
    6. We have a requirement in Spring LDAP for 1.4.2 regarding the base property. I'm currently investigating the validity of this.
    7. We suspect that the LDAP Booster Pack (ldapbp) pretty much requires JDK 1.4, but we need to investigate that further.

    Comment

    Working...
    X