Announcement Announcement Module
No announcement yet.
Spring Data Hadoop Build Errors Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Data Hadoop Build Errors

    I was trying to compile the source and the build seems to be failing for default hadoop 1.0.4 as well as 2.0.3



    Could not resolve all dependencies for configuration ':optional'.
    > Could not download artifact 'com.sun.xml.bind:jaxb-impl:2.2.3-1@jar'
    > Could not download artifact 'com.sun.xml.bind:jaxb-impl:2.2.3-1@jar'
    > Premature end of Content-Length delimited message body (expected: 890168; received: 0


    ./gradlew -Pdistro=hadoop20 build


    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not resolve all dependencies for configuration ':compile'.
    > Could not resolve group:commons-daemon, module:commons-daemon, version:1.0.3.
    Required by: > org.apache.hadoop:hadoop-hdfs:2.0.3-alpha
    > java.text.ParseException: inconsistent module descriptor file found in 'CachedResource: /home/hadoop/.gradle/caches/artifacts-15/filestore/commons-daemon/commons-daemon/1.0.3/pom/bdbf06d29718fbb259e2de51fc2ab91d4a92a800/commons-daemon-1.0.3.pom for': bad organisation: expected='commons-daemon' found='org.apache.commons';
    > Could not HEAD ''. Received status code 401 from server: Unauthorized

  • #2

    The 1.0.4 build looks like a temporary network glitch - could you pull the latest and try building again.

    There is an issue with the 2.0.3 build - one Hadoop dependency (commons-daemon) has an invalid pom and the build doesn't like that. More info here:

    We're working on providing a workaround, but until then you have two options.

    1) follow these instructions:

    2) If you have commit rights to the SpringSource repo you can provide your credentials in the init.gradle file - see:

    Let me know if you still see issues.