Announcement Announcement Module
Collapse
No announcement yet.
Spring-Data-Hadoop 1.0.0.M1 Maven JDO Dependency Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring-Data-Hadoop 1.0.0.M1 Maven JDO Dependency

    Hi all,

    I've just attempted to upgrade to Spring Data Hadoop 1.0.0.M1 after using snapshots, and now I get a Maven dependency failure:

    Code:
    Missing artifact javax.jdo:jdo2-api:jar:2.3-ec
    Nothing else has changed in my POM except the version of SDH.

  • #2
    Do you specify the jdo2-api declaration yourself? If not then most likely it's caused by org.apache.hive/hive-service which points out to this dependency that is not available in Maven central. One of our repo [1] hosts jdo2-api 2.3-eb (not ec). You should be able to fix this by either adding a repo that contains jdo2-api 2.3-ec or by excluding the dependency (potentially replacing it with 2.3-eb).

    Not ideal I know but there's not much we can do about this - we could try adding an exclusion on jdo-api but then that causes problems for those who use Hive....

    [1] http://repo.springsource.org/webapp/...t?1&q=jdo2-api

    Comment


    • #3
      By the way, for what it's worth the repo above is a 'gateway' for repo1.maven.org or maven central - so rather then adding our repo you could just use maven central directly.
      Hope this helps,

      Comment

      Working...
      X