Announcement Announcement Module
Collapse
No announcement yet.
gfsh is not connecting Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • gfsh is not connecting

    When I connection with

    connect -s localhost:40404

    it hangs forever and then finally returns....

    Error: Endpoints set but unable to connect: localhost:40404
    Error: gfsh is not connected to a server. Use the 'connect' command to connect first. aborting refresh
    Error: refresh -- IOException -- No Instantiator has been registered for class with id 311

  • #2
    gfsh requires that you add some entries to your classpath and to your cache.xml when you start your server. Did you add this stuff:

    Add to the cache.xml:
    Code:
       <region name="__command">
          <region-attributes data-policy="empty">
             <cache-loader>
                <class-name>
                   com.gemstone.gemfire.addon.command.CommandCacheLoader
                </class-name>
                <!-- allow some delay in msec for the server to initialize
                     the cache before initializing the command region. The
                     default value is 20000 msec. 
                -->
                <parameter name="initDelay">
                   <string>20000</string>
                </parameter>
                <!-- the command region path. This must match this command
                     region name. 
                -->
                <parameter name="regionPath">
                   <string>/__command</string>
                </parameter>
             </cache-loader>
          </region-attributes>
       </region>

    Add to the class path:
    addons/lib/gfaddon-util-60.jar
    addons/lib/gfaggregator-65.jar
    addons/lib/gfcommand-60.jar
    addons/lib/gfsh-65.jar

    See the gfsh readme for more info.

    Comment

    Working...
    X