Announcement Announcement Module
Collapse
No announcement yet.
Spring Gemfire POM Error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Gemfire POM Error

    I am attempting to run the Spring-Gemfire demo from the command line using the instructions and I keep running into a problem.
    To build the sample, use the following command:

    # mvn clean package
    To run the sample, use:
    # mvn exec:java

    I am in ./samples/hello-world

    Macintosh-6:hello-world hbrien$ mvn clean package
    [INFO] Scanning for projects...
    [INFO] ------------------------------------------------------------------------
    [INFO] Building Spring GemFire - Hello World Sample
    [INFO] task-segment: [clean, package]
    [INFO] ------------------------------------------------------------------------
    [INFO] ------------------------------------------------------------------------
    [ERROR] BUILD ERROR
    [INFO] ------------------------------------------------------------------------
    [INFO] Error building POM (may not be this project's POM).


    Project ID: org.apache.maven.plugins:maven-jar-plugin
    POM Location: /Users/hbrien/.m2/repository/org/apache/maven/plugins/maven-jar-plugin/2.1/maven-jar-plugin-2.1.pom

    Reason: Not a v4.0.0 POM. for project org.apache.maven.plugins:maven-jar-plugin at /Users/hbrien/.m2/repository/org/apache/maven/plugins/maven-jar-plugin/2.1/maven-jar-plugin-2.1.pom


    [INFO] ------------------------------------------------------------------------
    [INFO] For more information, run Maven with the -e switch
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: < 1 second
    [INFO] Finished at: Thu Sep 02 12:34:08 EDT 2010
    [INFO] Final Memory: 4M/81M
    [INFO] ------------------------------------------------------------------------


    ##################### VERSION INFORMATION ################
    Macintosh-6:hello-world hbrien$ mvn -version; java -version
    Apache Maven 2.2.1 (r801777; 2009-08-06 15:16:01-0400)

    Java version: 1.6.0_20
    Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
    Default locale: en_US, platform encoding: MacRoman
    OS name: "mac os x" version: "10.6.4" arch: "x86_64" Family: "mac"
    java version "1.6.0_20"
    Java(TM) SE Runtime Environment (build 1.6.0_20-b02-279-10M3065)
    Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01-279, mixed mode)

  • #2
    Hi,

    Could you try Maven 2.0.x since this is what we've been testing against (as mentioned in the readme.txt)? I have a feeling that 2.2 might not like something in your maven repo?

    Thanks,

    Comment

    Working...
    X