Announcement Announcement Module
Collapse
No announcement yet.
pom for gemfire Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • pom for gemfire

    I am trying to use spring-gemfire-1.1.0 with the following pom settings ...


    <dependency>
    <groupId>org.springframework.data.gemfire</groupId>
    <artifactId>spring-gemfire</artifactId>
    <version>1.0.1.RELEASE</version>
    <type>jar</type>
    <scope>compile</scope>
    </dependency>

    ...

    <repository>
    <id>spring-maven-release</id>
    <name>Springframework Maven Repository</name>
    <url>http://maven.springframework.org/release</url>
    </repository>


    and I get

    2/7/12 4:41:43 PM EST: Downloaded http://maven.springframework.org/rel...fire-6.6.1.pom
    2/7/12 4:41:43 PM EST: Downloaded http://repo1.maven.org/maven2/com/ge...fire-6.6.1.pom
    2/7/12 4:41:43 PM EST: [WARN] The POM for com.gemstone.gemfire:gemfire:jar:6.6.1 is missing, no dependency information available

    when I build and gemfire.jar is not in my local repo.

    What is the correct way for me to incorporate gemfire.jar into my build ?

    I can always install it into my local repo of course but I am hoping it is published somewhere.

  • #2
    found it

    Here:


    <repository>
    <id>gemfire-repository</id>
    <name>Gemfire Repository</name>
    <url>http://dist.gemstone.com/maven/release</url>
    </repository>

    Comment


    • #3
      <?xml version="1.0" encoding="UTF-8"?>
      <project>
      <modelVersion>4.0.0</modelVersion>
      <groupId>com.mirantis</groupId>
      <artifactId>cachemod-gemfire</artifactId>
      <version>1.0</version>
      <packaging>jar</packaging>
      <name>Mirantis Cachemod GemFire</name>
      <description>Mirantis Cachemod GemFire</description>
      <dependencies>
      <dependency>
      <groupId>com.mirantis</groupId>
      <artifactId>cachemod</artifactId>
      <version>${pom.version}</version>
      </dependency>

      <dependency>
      <groupId>gemfire</groupId>
      <artifactId>gemfire</artifactId>
      <version>6.5.1.4</version>
      </dependency>

      Comment

      Working...
      X