Announcement Announcement Module
Collapse
No announcement yet.
Spring-Data limitations on OSGi Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring-Data limitations on OSGi

    Hello friends,

    I'm very enthusiastic about spring-data and I'm eager to use it into my OSGi applications, but I'm concerned about the not yet release code. It would be nice to hear another experience and comments about:
    1. OSGified libs - i.e. if I want to import the libs from the OSGi environment, there's a already a bundle for exporting then? For which (sub)projects?
    2. If not, what's required for that, just a manifest? Someone can share it?

    thanks

    Paulo Machado

  • #2
    Hi,

    there had been an issue with our manifest files as we had misconfigured the Maven JAR plugin which in turn caused the Bundlor-generated manifests not ending up inside our release JARs. This should be fixed as of [1] (the ticket was filed against JPA but we have fixed that for Commons and Mongo as well). Beyond that it should be a matter of finding OSGi-ready JARs of the underlying datastore.

    Cheers,
    Ollie

    [1] https://jira.springsource.org/browse/DATAJPA-42

    Comment


    • #3
      I will keep an eye on this issue. Also, next time I'll take a look in the jira before asking in the forum.

      Thanks for the reply,
      cheers
      Paulo

      Comment

      Working...
      X