Announcement Announcement Module
Collapse
No announcement yet.
Connections not released in Tomcat 6 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connections not released in Tomcat 6

    I am extending my dao impl classes from NamedParameterJdbcDaoSupport. I hae deployed my code in the local tomcat version 6.0.x. I see that the connections are created and released as expected. But in the testing environment the created connections are not getting released. I am unable to figure out the problem.
    I havenot configured anything exclusively in my local tomcat config files: context.xml / server.xml. Am I missing something??

    My bean configurations are:
    <bean id="oracleDataSource" class="org.apache.commons.dbcp.BasicDataSource" destroy-method="close">
    <property name="driverClassName" value="$[db.driver]" />
    <property name="url" value="$[db.url]" />
    <property name="username" value="$[db.user]" />
    <property name="password" value="$[db.password]" />
    <property name="defaultAutoCommit" value="true" />
    <property name="removeAbandoned" value="true"/>
    <property name="removeAbandonedTimeout" value="60"/>
    <property name="logAbandoned" value="false"/>
    <property name="maxActive" value="20"/>
    <property name="maxIdle" value="10"/>
    <property name="maxWait" value="-1"/>
    </bean>
    <bean id="xxDao" class="com.xx.xxDaoImpl">
    <property name="dataSource" ref="oracleDataSource" />
    </bean>
    Help is appreciated.
Working...
X