Announcement Announcement Module
Collapse
No announcement yet.
Hibernate 3.3 dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hibernate 3.3 dependencies

    Hi

    I'm setting up a development for Spring + Hibernate.

    The Hibernate 3.3 core distribution contains the following libraries:
    hibernate-distribution-3.3.1.GA\lib
    bytecode\cglib
    bytecode\javassist
    optional\c3p0
    optional\ehcache
    optional\jbosscache
    optional\jbosscache2
    optional\oscache
    optional\proxool
    optional\swarmcache
    required\antlr-2.7.6.jar
    required\commons-collections-3.1.jar
    required\dom4j-1.6.1.jar
    required\javassist-3.4.GA.jar
    required\jta-1.1.jar
    required\slf4j-api-1.5.2.jar


    I think I must include required\*.jar into my classpath, but how do I choose the libraries in bytecode and optional directories?

    What are the minimal libraries to run Hibernate?

    Please help, thank you!
Working...
X